Topology Editor Manual

Sandra Moral Boadas

Report LSI-97-16-T
1. INTRODUCTION

This report gives detailed information about the Topology Editor use and implementation. Topology Editor is under the scope of the DSP tool (the specification and design can be found in [1] and [2]). DSP tool is a simulator that has, as main goal, the simulation and testing of the theoretical distributed algorithms in Distributed Computing area (see [3]). In a simulation the user has to describe the network topology, the special software and hardware characteristics of all nodes and links. Topology Editor is a graphical tool of DSP designed to make easy the topologies management. The tool ambition is make a friendly user interface, making easily the definition and refining of a topology. Using the Topology Editor a user can define with a very flexible interface the topology layout and the topology parameters values needed on a simulation.

Before introducing the implementation Topology Editor, objectives can be found in section 2. To check this objectives reader can follow the user manual presented in section 3. And, once the friendly user interface is presented the implementation is detailed (section 4).

2. OBJECTIVES

Topology Editor tool provides topologies that can be used as a input on a simulation using the DSP simulator. In order to increase the flexibility and the scale of reusability of the tool, the topology generated is written in a specific topology language (DSPL). This topology language can be used mainly to describe large networks (e.g. networks with hundreds or thousands nodes) or small networks (e.g. networks with up to twenty nodes). This description language provides information about:

* topology parameters definition (e.g. a node initial local clock or a link queue size),
* definition of network topology (e.g. which is connected to which),
* definition of the special characteristics of each link (e.g. transmission delay, bandwidth, failures),
* definition of special pre-defined topologies (rings, general graphs, trees, complete graphs).

The BNF notation of the topology language is given in [4].
3. INTERFACE

The user can create a new topology using a very clear interface by drawing nodes and links in the drawing area. User can also define (pointing and clicking) the topology characteristics concerning nodes, links and special topology parameters. Topology Editor provides also a graphical way of grouping nodes and links.

Large topologies that consist of many nodes or links can not be described by pointing and clicking. For this case, the DSP Topology Language Editor can be used for both standard topologies or general topologies.

A user can perform the following operations:

. delete nodes or links (see section 3.1.),
. modify the location of the nodes and the link’s arcs (see section 3.1.),
. create a new topology (see section 3.2.),
. save a topology on a file (or restore it) (see section 3.3.),
. exit program (see section 3.4.),
. create new nodes in a topology (see section 3.5.),
. create new unidirectional (or bi-directional) links (see section 3.6.),
. change the topology parameters values (see section 3.7., section 3.8. and section 3.9.),
. create or destroy nodes and links groups (see section 3.10. and section 3.11.),
. arrange nodes and make lines the link’s arcs (see section 3.12).
. obtain a postscript file with the topology graph (see section 3.13).

The main window is divided in three parts (Figure 1): menu, button bar (with the most used functions), and the drawing area (where topology graph is drawn).

![Topology Editor](image)

Figure 1 - Main window

In the following sections can be found detailed information about how to use Topology Editor.
3.1. Select mode

Topology Editor is in select mode when the user has chosen the ‘Select’ option from menu ‘Edit’ or has pressed the arrow button ▼. In this mode mouse pointer is an arrow. Select mode is used for selecting and then move nodes and links. Selections of nodes or links can be done moving the mouse holding pressed the mouse button or clicking into the object.

When user is selecting an area (dragging the mouse before release it) a square is displayed. In this way user knows the area selected. A node that belongs to this square area will be selected although it won’t be completely inside this area.

A user can select some objects scattered on the drawing area holding the CTRL key pressed while the user clicks on the objects.

When some objects are selected, user can move this selection just pressing on it and dragging it to another position in the drawing area. During a movement all the links that connect the moving partition and the static partition of the topology are repainted and adjusted to the new position automatically.

In select mode the user can delete objects and groups of objects. First of all he should select the objects and then press delete key or select ‘Delete’ from ‘Edit’ menu.

3.2. New topology creation

User can create a new topology just selecting the option ‘New’ from ‘File’ menu or clicking △ in the bar button. When this action is done user shall choice the type of the new topology (see Figure 2) and fill in some parameters. If the topology type is:

* general topology, user can draw nodes and links with any distribution.
* ring topology, user shall define the number of nodes of the new ring and Topology Editor will draw it.
* tree topology, user shall define the high and breadth of the new tree and Topology Editor will draw it.
* complete topology, user shall define the number of the new complete topology and Topology Editor will draw it.

If a special topology (ring, tree, complete) is selected then the user could change its layout and the parameters without changing the topology type. But if the user delete or add objects to the topology, he should change its special type to ‘general topology’ type. We are trying to check if the topology is still a special topology (see Future Work 10).
When the OK button is pressed the old topology drawn on the drawing area is deleted. We are trying to improve this action (see Future Work 14).

3.3. **Save and restore topologies**

The ‘Save’ (or ‘Load’) option from ‘File’ menu are used for restoring or saving a topology. Another way to activate this action is with the ‘Save’ (or ‘Load’) button in the button bar (or ). When this action is activated the file save (or restore) dialogue window is displayed (Figure 3) and the user can select a name file.
User can change its directory to load or store the topology files, increasing the interchange facility of them.

3.4. **Topology Editor Exit**

When a user wants to quit the program he can select ‘Exit’ from ‘Files’ option or can press exit button ☐ in button bar.

3.5. **Drawing nodes**

The user can always draw new nodes. Each node is represented by a circle. Nowadays the node identifier is inside the circle, but we are working to let the user choice if this identifier should be displayed or not (see Future Work 6).

To draw new nodes user should be on new node mode. To be in new node mode user can press new node button ☐ or choice the ‘New Node’ option from ‘Edit’ menu. When one of this activate new node mode is done a new mouse pointer (like this circle ○) is displayed. Once the new mouse pointer is active user can press right mouse button to insert a new node.

When a user is in new node mode and he performs a double click in a node, the node parameter window is displayed, making easy parameter changes.

3.6. **Drawing links**

The user can always draw new unidirectional or bi-directional links between drew nodes. Each link is represented by a line ended with an arrow (if is unidirectional) or with two arrows (if is bi-directional). Nowadays the line is continuous and the kind of arrow is standard, but we are working to change it and give to the user the possibility of change these lines and arrows (see Future Work 4).
To draw new links user should be on new link mode. To achieve new link mode user can press unidirectional link button (or if wants to draw bi-directional links) or choice the ‘New Unidirectional Link’ (or ‘New Bi-directional Link’) option from ‘Edit’ menu. When one of these new link mode activation is done, mouse pointer changes to (or this if is bi-directional link ). Once the new mouse pointer is active user should press in the starting node (from the link starts) and then press in the end node (where the link end). Between these two button actions a line helps the user to make an idea of the final draw of this new link.

The line that connects the two nodes can be modified after its creation. It can be achieved just selecting the link (pressing it on a select mode) and dragging it.

When a user is in this new link mode and do a double click in a link, the link parameter window is displayed, making easy parameter changes.

### 3.7. Node parameters definition

To change a parameter of a node, user should change to view parameters node mode. It can be done selecting the ‘Node’ option from ‘Parameters’ menu or pressing the button . When one of this actions is done the mouse pointer changes to . User will obtain all the parameters information of a node just making a double click over it, and then, with a very flexible interface, he can change the node parameters values.

The topology characteristics concerning a node are: processing step, clock step, clock drift, clock start, type of node failures (if the node is not reliable and is assumed to fail during the simulation), the node’s input and output queue size and some parameters that depend on the timing and distribution type of the topology (see Table 1).

<table>
<thead>
<tr>
<th>Topology Distribution Type</th>
<th>Special Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>synchronous</td>
<td></td>
</tr>
<tr>
<td>asynchronous</td>
<td>Timing</td>
</tr>
<tr>
<td></td>
<td>uniform</td>
</tr>
<tr>
<td></td>
<td>lower limit, upper limit</td>
</tr>
<tr>
<td></td>
<td>geometric 1</td>
</tr>
<tr>
<td></td>
<td>lower limit, upper limit, mean</td>
</tr>
<tr>
<td></td>
<td>geometric 2</td>
</tr>
<tr>
<td></td>
<td>lower limit, upper limit, mean</td>
</tr>
<tr>
<td></td>
<td>normal</td>
</tr>
<tr>
<td></td>
<td>mean, upper limit, variance</td>
</tr>
<tr>
<td>archimedian</td>
<td>maximum to minimum delay ratio</td>
</tr>
<tr>
<td>abd</td>
<td>maximum delay</td>
</tr>
</tbody>
</table>

Table 1 - Special node parameters according to the timing and distribution type of the topology.

Because of this timing and topology distribution dependency when a user has some parameters windows and the topology parameters change, all the nodes parameters displayed are refreshed. Some examples of these different windows parameters can be found on Figure 4.
Figure 4 - Node parameters windows with some different topology time distribution.
We are working to offer the possibility of change all parameters of all nodes members in a group to increase the speed of the parameters modifications (see Future Work 9) and we are also working on reset the parameters by default (see Future Work 15).

3.8. Link parameters definition

To change a parameter of a link, user should change to view parameters link mode. It can be done selecting the ‘Link’ option from ‘Parameters’ menu or pressing the button . When one of this actions is done the mouse pointer is . Just making a click over a link a link parameter window is displayed. User can define with a very flexible interface the link parameters values necessary in a simulation.

The topology characteristics concerning a link are: the transmission delay, the bandwidth (that denotes the messages that can travel through the link per time unit), the weight, the option of the existence of conflicts on the link and the type of link failure (if the link is not reliable and is assumed to fail during the simulation). The delay distribution is a parameter that depends on the timing and the distribution type of the topology (as seen above with the step duration distribution of a node, see Table 1).

Because of this dependency of the timing and topology distribution type, when a user has some parameters windows and the topology parameters changes, all the link parameters displayed are refreshed. Some examples of this different windows parameters can be found on Figure 5.

![Figure 5 - Link parameters windows with some different topology time distribution.](image)

We are working to offer the possibility of change all parameters of all links members in a group to increase the speed of the parameters modifications (see Future Work 9) and reset the parameters by default (see Future Work 9).

3.9. Topology parameters definition

To change a topology parameter user should change to view parameters link mode. It can be done selecting the ‘Topology’ option from ‘Parameters’ menu or pressing the button . User will obtain all the topology information. If the user update some parameters the other parameters windows that can be displayed should be repainted to update the parameters wanted. The topology parameter window is the window shown on Figure 6.
3.10. Grouping nodes or links

Topology Editor offers to the user the possibility of make groups of nodes (and groups of links) with a very simple process, building topologies clearly and easily.

To create a new group of nodes (or links) first of all the user should select the nodes (or links) that will belong to this group. Once the nodes are selected user should press the group button or select the option ‘Group’ from ‘Edit’ menu. A question window will be displayed asking for the identifier of the new group. If the group identifier doesn’t exist the nodes will be the first nodes (or links) that belong to this group. If the group exist the nodes (or links) will be append of this group.

All the elements of a group will be painted with the same colour to a better distinction between the groups. Nowadays a group of links could have the same colour than a group of nodes but we are working to solve this conflict to help user to recognise the groups. We have only a set finite of groups identifiers and we are working also to extend it (see Future Work 3 and Future Work 15).

3.11. UnGrouping nodes or links

Topology Editor offer two ways to ungroup some objects from a group. One is group this objects in a new group, and the other option is selecting these objects, and press the ungroup button or the option ‘Ungroup’ from ‘Edit’ menu. If an object is ungrouped it become one of the member of the default group. Nowadays the default group is number 1 with black colour, but we are working to allow the user to change the values by default (see Future Work 16).
3.12. **Arrange nodes**

After some changes in a topology drawing and moving actions user would probably like to restructure nodes in drawing area. To help user in this action Topology Editor offers three options from ‘Options’ menu: ‘Arrange graph’, ‘Straighten’ and ‘Resize Node Bubbles’. ‘Arrange graph’ sort the nodes on a circle and ‘Straighten’ makes a line the selected link. ‘Resize Node Bubbles’ changes the radius of nodes to a new value entered by the user.

3.13. **PostScript output**

User can save the drawing area on a postscript file. This is useful for the documentation research. The option ‘postscript’ from ‘File’ menu generates this file.

4. **MODULES AND PROCEDURES**

The Topology Editor includes:
* user interface for the creation and testing of a new or the modification of an existing one.
* editor for the creation and testing of a new topology through the DSP Topology Language.

4.1. **Function distribution**

Implementation is doing with Tcltk language. There are eleven modules:

<table>
<thead>
<tr>
<th>Module name</th>
<th>Type of functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>About</td>
<td>Functions for display help information.</td>
</tr>
<tr>
<td>Graph</td>
<td>Functions related with the layout of the topology.</td>
</tr>
<tr>
<td>Select</td>
<td>Functions related with movements of the topology graph.</td>
</tr>
<tr>
<td>ValueDef</td>
<td>Functions for initialization of topologies structures.</td>
</tr>
<tr>
<td>Checker</td>
<td>Functions to check parameters and connectivity features.</td>
</tr>
<tr>
<td>Group</td>
<td>Functions related with group and ungroup topology elements.</td>
</tr>
<tr>
<td>Special</td>
<td>Functions related with special topologies.</td>
</tr>
<tr>
<td>Window</td>
<td>Group of functions that control window operations.</td>
</tr>
<tr>
<td>FileProcs</td>
<td>Functions to manage input and output topology files.</td>
</tr>
<tr>
<td>Params</td>
<td>Functions related with the parameters input and output window.</td>
</tr>
<tr>
<td>Main</td>
<td>Function that controls all the Topology Editor.</td>
</tr>
</tbody>
</table>

A graphical representation of the previous table is done in Figure 7.
5. **FUTURE WORK**

In order to improve the flexibility and the friendly use capabilities of the Topology Editor we are developing the following features:

1. Offer an interactive help.
2. Allow the user to change all the parameters values in a group in parallel.
3. Show to the user the actual groups colour and let change it.
4. Let choose if end arrows of bi-directional links should be displayed.
5. Undo operations.
6. Let choose if the nodes identifiers can be displayed or not.
7. Work with more than one topology together.
8. Show groups of nodes by levels.
9. Reset values of some parameters.
10. Try to conserve the topology type unless change operations has been done.
11. Choose links lines (e.g. discontinuous line could be for Byzantine links)
12. Preview a topology before load it.
13. Cut, copy and paste between topologies.
14. Allow to save changes on a topology before create another new one.
15. Change the number identifier of the nodes into a customise node identifier.
16. Let to the user customise the value default simulation parameters and Topology Editor options.

**REFERENCES**


*This work has been supported by ESPRIT LTR Project no. 20244 - Alcom-IT.*