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1. Introduccion

El sistema grafico de MATLAB permite:

e Visualizar datos mediante comandos de alto nivel. Esto incluye la visualizacion
en 2y 3 dimensiones, el procesado de imagenes/fotos, la elaboracion de graficos
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para presentaciones (diagramas de barras, de queso) y la inclusién de efectos (de
animacion, iluminacion, movimientos de caAmara).

e Crear y manipular objetos graficos mediante comandos de bajo nivel. Se trata
de las herramientas del GUI (Graphics User Interface) que permiten la
programacion de aplicaciones orientadas al usuario, con ventanas, mends y
controles. Estas herramientas son las que se veran en el presente tema.

2. Graphics User Interface (GUI)

El GUI (Graphics User Interface) de MATLAB es el conjunto de herramientas y
comandos de bajo nivel que permiten crear y manipular objetos graficos con el fin de
desarrollar aplicaciones “amigables” para el usuario.

Los objetos graficos de MATLAB presentan la siguiente jerarquia:

root
figure
|
uicontrol axes uimenu
Push Button | — line
Toggle Button [ - surface
Radio Button | | patch
Check Box | L image
Edit Text L1 text
Slider L light
Active X Control [ B
Pop-up Menu [
Panel

Button Group [

Fig. 1. Jerarquia de los objetos graficos en MATLAB.
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Objetos: El objeto root es la pantalla principal. Ningun objeto de los anteriores puede
existir si no existe root (es decir, si no esta abierto el programa MATLAB no podemos
tener ni figure’s, Ni axes, etc.).

Cuando en root hacemos >>plot(t,y) se crean todos los objetos necesarios para la
representacion grafica de y en funcién de t (Figure = axes = line), Si €S que antes no
existian.

Handle y propiedades: Todos los objetos gréaficos tienen un handle (nimero que lo
identifica) y un conjunto de propiedades (Color, Position, etc.). Algunas de las
propiedades pueden modificarse pero otras no. El handle del objeto root es 0.

Las propiedades de los objetos son accesibles desde los comandos de texto de bajo nivel
(set, get) y desde las herramientas del editor grafico guide (Property Inspector,
Object Browser, Menu Editor).

3. Comandos de bajo nivel: sety get

Los dos comandos de texto de bajo nivel son get y set. El primero devuelve el valor
de una, varias o todas las propiedades de un objeto grafico y el segundo las modifica (si
es posible).

La funcion set también puede utilizarse para ver qué propiedades son modificables y
cuales son los valores validos. Por ejemplo, ver qué sucede al teclear:

>> set(text)

Ejemplo 1. Objetos, identificadores (handles) y propiedades

1) Generar un vector temporal de 0 a 20s en pasos de 0.1s y representar la curva
y =t-sin(t) con ayuda de la funcion plot.

B LR few Fowt Lok g teb

DEES& kAA, 2O0

» t=0:0.1:20;y=t.*sin(t);plot(t,y)

%

2) Obtener el identificador del objeto figure actual.

» gcf §
ans =
1 -15 .
Nota: gcf significa Get handle to Current Figure A

Nota: gca hace lo mismo que gc¥ pero para el objeto axes y gco es para
cualquier tipo de objeto (hay que seleccionarlo antes).

» gca
ans =
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102.0009

» gco Y% antes hay que haber clicado en el objeto line de la fig
ans =
4.0002

Nota: clicar ahora en los ejes y ver que efectivamente gco devuelve el handle
correspondiente al objecto axes.
» gco

ans =
102.0009

3) Obtener las propiedades “‘Color’ y “Position’ de dicha figura:

» get(gcf,"color™)
ans =
0.8000 0.8000 0.8000

» get(gcf, "position®)
ans =
232 258 560 420

Nota: los nombres de las propiedades se pueden abreviar (si no existe posibilidad
de confusién). Asi, también se pueden utilizar, entre otras, las siguientes
expresiones:

» get(gcf,’pos”)
» get(gcf,’Posi’)

4) Modificar la propiedad ‘Position’. Determinar a qué se refiere cada una de las
cuatro componentes del vector

» set(gcf, "pos”,[608 95 110 300])

;.
- MATLAB al Limites
File Edit View wWeb Window Help de Ia

0O = W 7 | Current Directory: | CwaTLABER! wwark - J
: pantalla
oA MATLAR || |== Jl:20;y=t.*sinit);plot(t,y)
[}ﬂ Commmications Toolbox >> getiget, 'color') < >
B-ofk Control System Toolbox ans =

F 1
[}ﬂDa\:a Acquisition Toolbo: e Ldt gew

Insert  Took

]—ﬂData}Jasa Toolbox 0.§000 0.g000 0.g000

}ﬂDa\:aEeed Toolbox 3 getigef, 'pos') DEES

#-ofl Filter Design Toolbox
ans =

}ﬂ Financial Deriwatiwves To

}ﬂ Financial Toolbox
#-of\ Fuzzy Logic Toolbox
+-of\ GARCH Toolhox ans =
#-of\ Tnage Processing Taolhox .
| JJ

»

| ‘ Launch Pad Workspace »> setigof, 'pos',[608 95 110 300])

B
EE
Loommumeplv| | F ok 4 608 0 X

All files |F1].a ﬂ Last
(C3 seniMaT Folder 15-m%
. e 95 |
4| ‘ Current Directory [ [

Ready

f /‘Iﬁ il 30

[
[
[
[
Bl Financial Time Series To 120 90 se0 4z0
[
[
[
[
q

m o ;o ;o e o

Fig. 2. Propiedad “Position”
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5) Ver todas las propiedades de la figura actual con ayuda de get (De qué objeto es
padre (ver propiedad ‘Children’)? ;De qué objeto desciende (ver propiedad
‘Parent’?:

» get(gcf)

6) Ver todas las propiedades que es posible modificar con ayuda de set ;Qué
propiedades no es posible modificar?

» set(gcft)

7) Cerrar todas las figuras:
» close all

y verificar que hacer

» line

es equivalente a hacer

» Figure
» axes
» line

Notar lo que hace cada instruccién y como va la numeracion de los objetos.

Sugerencia: Repetir para el resto de objetos graficos, hacer por ejemplo:

» uicontrol
» patch
» surface

etc.

4. Editor de propiedades
4.1 Editor de propiedades en la version 6.x

Ejemplo 2. Editor de propiedades en la v6

Volver a representar la curva y =t-sin(t) en funcion de un vector temporal de 0 a 20s

en pasos de 0.1s y ajustar de nuevo la propiedad Position del objeto Figure que
contiene la representacion.

>> t=0:0.1:20;y=t.*sin(t);plot(t,y)
>> set(gcf, "pos*,[608 95 110 300])

Property Editor: Para entrar en el editor de propiedades seleccionar, en la propia figura,
la opcion Edit > Figure Properties... Notar que el editor tiene dos areas:
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en la superior hay una lista de los objetos gréaficos existentes (ordenados
jerarquicamente) y, en la inferior, estan las propiedades asociadas al objeto seleccionado
en la lista anterior. Notar también que, al seleccionar un objeto desde el editor, éste
aparece seleccionado en la figura.

¥7 Property Editor - Axes

<) Fi... @)X

Ql
Ready

Apply

Edit Properties for, [ELraE - ﬂJ File Edit Wiew
H Insert  Tools
Scale root : 0 b I
I Style figure : 1 window Help
Lirnits ¥ Auto T Line : I T I T DedS
Ticks Auto| v Auto‘ v Aulo‘
Labels W Auto E‘ W Auto :I ¥ Auto E‘
Scale @ Linear #*+ MNormal @ Linear #* Normal @ Linear * Mormal
¢ Log {" Revarse " Log {" Reverse " Log {" Reverse
Grid [~ Show [~ Show [~ Show :
1
Setaxes auto shape| Settight limits |
y
)
1
Hel e -@o- -=m
_ He | o 10 20

Cancel | ‘IV Immediate apply

Fig. 3. Editor de propiedades en la version 6.1.

¥i Property Editor - Axes
Edit Properties for: jaxes: v| [E]
! W z Style Aspect Lights Wiewpoint Infa
Label | HF‘eremes...l
calor: |E|\am-( v| Customn color,
Lacation: |Elort0m v| 3 Figure No. 1 LER
Grid: [] Show File Edt View Insert Todls
window  Help
Limits: [#] auto ‘ H ‘ DEEHS A A/
Ticks: [v] Auto ‘ |
Labels: [¢] Auto
Scale: (® Linear () Normal
CrLag () Reverse
[Set anes auto shapel [Sett\ghtlimilsl
o] o ] o ]
Immediate apply

Fig. 4. Editor de propiedades en la version 6.5.

4.2 Editor de propiedades en la version 7.x

Ejemplo 3. Editor de propiedades en la v7

Volver a representar la curva y =t-sin(t) en funcion de un vector temporal de 0 a 20s
en pasos de 0.1s.
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>> t=0:0.1:20;y=t.*sin(t);plot(t,y)

Property Editor: Para entrar en el editor de propiedades seleccionar, en la propia figura,
la opcion Edit - Figure Properties... o bien View > Property
editor. Notar que si se selecciona uno de los objetos, aparece el editor de
propiedades correspondiente al objeto seleccionado:

) |Figure 1 =3 )|Figure 1 [ (=) ]

Fle Edt Yiew [nsert Toolk Desktop Window Help Fie Edit ¥ew Insert Tools Deskiop Window Help

neda (k] &a®e)E0H o0 Deds (kaama v 08 oQ

208 =

| [Property Editor - Figure x || Property Editor - Axes x| |
FweName: | | [Z]Show Fioure Number Tite: s asts | v pis | Zods | Fort Inspector

Figura Color
coos: (&7 [ rims[d Jo[m ] Blaus
S D

Box

Fig. 5. Editor de propiedades en la version 7.0.4.

4.3 Modificacién de objetos con el editor de propiedades

Ejemplo 4. Modificacion de propiedades v6 y v7

Version 6.x: Modificar el color de fondo del objeto
figure a verde (Green o [0 1 0]: recordar que el
EEE

color es la terna con los porcentajes de RGB) y R T
cambiar también la propiedad Position. Para
modificar el objeto axes, seleccionarlo en la lista ' ]
de objetos y escribir las nuevas coordenadas
(también es posible, y mas comodo, ajustar los ejes
con ayuda del raton: clicar con el derecho sobre los
ejes, seleccionar la opcion Unlock Axes
Positiony arrastrar).

Version 7.x: Maodificar el color de fondo del objeto
figure a verde (para ello usar el boton “Figure
Color”). Asimismo, modificar el tamafio del objeto
figure con ayuda del raton. Para modificar el
objeto axes, clicar sobre él y arrastrar su contorno
con el raton a fin de hacerlo mas pequefio.

ETSETB. MATLAB. Fundamentos y/o Aplicaciones. Curso 11/12b 7



Tema 4. Interficie grafica con el usuario

Ambas versiones: Salvar la figura (F1le->Save) como ejemplo4.fTig y cerrarla.
Para volver a abrir la figura se puede hacer:

>>openfig(“ejemplo4”)

5. Panel de controles. Utilidad GUIDE

Clicar en = 0 bien desde la ventana de comandos hacer >>guide Y, desde ahi, abrir el
fichero creado en el ejemplo anterior ejemplo4.fig. También es posible hacer
>>guide(“ejemplo4>). (Nota: Si en la version 7 aparece un cuadro de axes con la
leyenda scribeOverlay, clicar sobre él y borrarlo).

Paleta de controles: Por defecto, en la libreria de objetos s6lo aparecen los iconos. Si
se quiere ver el nombre completo de cada objeto ir a File>Preferences.. Y
seleccionar la opcion Show names in component palette.

5.1 Creacion y edicion de objetos desde la utilidad GUIDE

Creacion y alineacion de objetos: Arrastrar dos botones (push button) a la figura y,
opcionalmente, alinearlos a partir de la opcion de mend Tools>Align Objects.. 0 a

partir del icono correspondiente =l

</ tutorial.fig
File Edit Wew Layout Tools Help

o \ = B | o as i —
D& & L2l B =% r1— 2 Figure Mo. 100.002319 BEEE
IT 1.0 Edt Wiew Insert Tools MWindow Help
o —
<} Align Objects
DN GE
= Vertical
i Align orf | O0F jelE glg
=1l || 25 Distribute —ot| 22(23{ S
Eid = £l
04r
. . Horizontal
Push Butt
po| PusnBton Dusfioiten] Align wr B &3
Distribute ”."P|EF ooed
r [207
Apply

Fig. 6. Alineacion de objetos (v6.x)
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5.2 Object browser. Propiedades Tag y String

Para abrir el Object Browser se puede hacer desde el menl View>0bject Browser 0O

bien clicando en el icono * . Enel Object Browser aparece la lista de todos los objetos
creados en la GUI (ver Fig. 7).

Propiedades Tag y String: En concreto, en el Object Browser aparecen entre paréntesis
las propiedades Tag y String de cada objeto.

El Tag es un alias (nombre) que permite referenciar los objetos sin tener que recurrir al
numero de handle. En la Fig. 7 los Tag de los dos botones son pushbuttonl y
pushbutton2. Estos son los nombres que GUIDE les da por defecto, lo habitual es que
el usuario cambie estos Tags Yy los sustituya por otros nombres mas relacionados con lo
gue hacen los controles al activarse.

La propiedad String hace referencia al texto que aparece sobre cada control (notar que
se muestra entre comillas). En la Fig. 7 el nombre (String) que aparece sobre cada
botdn es Push Button. Este también es el String por defecto para los botones.

Para acceder a la totalidad de las propiedades de un objeto se puede hacer clicando
sobre el objeto o clicando sobre su nombre en el Object Browser.

5.3 Property Inspector. Modificacion de propiedades

Para abrir el Property Inspector se puede hacer desde la opcion del mend

View>Property Inspector, 0 clicando sobre el icono B3, o haciendo doble clic en el
objeto en cuestion, o clicando sobre el nombre del objetos en el Object Browser. En el
Property Inspector aparece la lista de todas las propiedades del objeto asi cémo los
valores asignados a estas propiedades (ver Fig. 7).

& ejemplo3.fig Q@@l Es Property Inspector Q@@|
File Edt Wiew Layout Tools Help [28] wicontrol (pushbutton2 "Push Button™
o . & Ior ) | ~
D = E é{’ v % E&I % s BeingDeleted D
BusyAction Bqueue
ButionDownFen
CData [EI)(EI double array]
Callback
Clipping E]nn
CreateFcn
DeleteFen
/ Enabls *en
- Bxtent
FontAngle Bnurma\
Fontame WS Sans Senf
FontSize 80
FortUnits (=] points

2 Object Browser,

Push Button
—

Push Button I

Fig. 7. Object Browser y Property Inspector (v7.X)
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Modificacion de las propiedades de un objeto (String y Callback): Seleccionar, con el
raton o desde el Object Browser, uno de los botones.

Hacer doble clic sobre el botén

seleccionado para abrir el Property i Propertynsperton
. - uicontrol (grid on’

InSpECtor Camblar Ias propledades —HUrizunt;AIign;nem :Icemer ;l
String y CalIBack escribiendo en ambas [ erpthe <o
grid on, pulsar <enter>y cerrar. Idem - ax 10

s s _ — Min 0.0
con el otro botén pero escribir grid off. i1 Position [0,602 0,261 0,251 0,061]

| SelectionHighlight ~|on

- SliderStep [0,010,1]
i

La propiedad String hace referencia al

| Style

teXtO que a'pareceré SObre el bOtén La _?gn — pushbutton2

1 - \— TaolipString
propiedad Callback hace referencia al - Ucertoen | <one> |
comando o comandos de usuario que se Ryl P ]

ejecutaran al ser pulsado el boton. Fig. 8. Modificacion de propiedades

Activar la Figura clicando en '™ o bien desde el men( (Tools>Activate Figure) 0

(Tools=>Run, segun la version). Una vez activada ya es posible ejecutar los controles:

J Figure Mo, 1 EEE ) Figure No. 1 EEE
File Edit Wiew Insert Tools ‘Window Help File Edit View Insert Tools “Window Help

A\

Fig. 9. Verificacion del comportamiento de la GUI una vez activada

Propiedad NextPlot: A veces, al crear un objeto grafico (por ejemplo, unos axes) es
deseable cambiar las propiedades por defecto y poner otras (cambiar el color, los limites
de los ejes, poner una rejilla,...). Estas propiedades del objeto axes se pueden perder
en situaciones donde, como respuesta a la activacion de otros controles, en estos axes
se va cambiando el objeto hijo line representado (por ejemplo, al hacer clic en un
botdn se representa un seno y al volver a hacer clic un coseno). Para evitar esto hay que
modificar la propiedad NextPlot. Los valores posibles son:

e New: Se crea un objeto (Figure 0 axes) nuevo cada vez
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e Add: se usa el objeto tal como esta

e Replace: se eliminan todos los objetos hijos (Iine,...) anteriores y se resetean
todas las propiedades excepto la posicion

e Replacechildren: se eliminan los objetos hijos pero no se resetean las
propiedades

Otros comandos relacionados con la limpieza de la pantalla son nextplot y drawnow.

5.4 Menu Editor. Funcion findobj

Para abrir el Menu Editor puede hacerse desde la opcién de mend Tools>Menu
Editor.. 0 bien clicando en el icono &,

Siguiendo con el ejemplo vamos a crear un nuevo menu de nombre “grids” con dos
opciones (items) “grid on” y “grid off” que hagan lo mismo que los botones anteriores.

Para crear un nuevo menu clicar en E'. Asignar el valor “grids” a la propiedad Label
y a la propiedad Tag. Label es el nombre que saldra en el mend.

Crear dos submenus (clicar en =) dependientes del mend “grid” con las propiedades
Label y Callbacks grid ony grid off. Notar que, para establecer qué menus cuelgan
de cuéles, se pueden utilizar los simbolos (2, <, 4, 1).

Una vez editados los menus, cerrar el editor, activar la figura y verificar su
comportamiento.

<} Menu Editor
= o T [b]

J |Figure No. 1
File Edit W%iew Insert Tools Window Help

UlMenu Properties
Lakel: |grid off

Tag: [menu_12

[” Separator above this item
[~ Itern is checked
Callback:

=] orids ‘gnd o
= grid an
=Y oirid off

- LLEF (P [ (1P [0 (TR [P [OF

) GUIDE BEEE

Activating will save changes to your figure and M-file. Da pou wish to continue?

Dant el y
Menu Bar | Cortext Menus I Don' tell me again

Fig. 10. Edicién de menus (v6.x)

Funcion findobj: Una funcién atil en el desarrollo de aplicaciones es la funcion
findobj, que devuelve el handle de todos los objetos cuya propiedad tiene un
determinado valor. Por ejemplo, si tenemos varias opciones de menu y queremos saber
cudl esta seleccionada podemos hacer:
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h=Findobj (" Checked”,"on");

Editor de propiedades: Notar que los nuevos objetos (controles y menls) ya seran
modificables desde la Figura (Edit>Figure Properties) sin necesidad de volver a
abrir el guide:

¥7 Property Editor, - Uimenu
Edit Properties for; | S - ﬂJ
root : 0
sye | o ||™°5 e
l—. uimeru : 'menu 1! ——
Label forid of uimenu : 'menu 12'
Specify uimenu : 'menu 11' ing
appeary uicontrol : 'pushbuttonz’' splay
the "&" uicontrol : 'pushbuttonl’'
- legend : 'legend'  —
Callback |arid off legendline : 'datal'
axes §
¥ Enahle menu b line :
[™ Check markta left of menu iterm
™ Separator line above menu item
0128 | Cancel | Apply |I7 Immediate apply Help
Ready

Fig. 11. Editor de propiedades en v6.x

Finalmente, si ya se tiene una figura abierta y se quiere abrir el guide para editarla o
afiadirle objetos, es posible hacer >>guide(gc¥T).

6. Desarrollo de aplicaciones

Los pasos para el disefio de aplicaciones son los siguientes:
1. Hacer un croquis de la apariencia que debe tener la GUI y su funcionalidad.

2. Crear la ventana principal y arrastrar a ella todos los controles. Alinear, distribuir y
ordenar los controles.

3. Establecer las propiedades de los controles. Algunas de las propiedades tipicas que
se establecen en esta etapa del disefio son: String; Tag; Color; en cuadros de texto:
BackgroundColor, ForegroundColor, FontSize...; en paneles: Title; en figures:
Name; en axes: XLim, YLim,...

La propiedad callback es la propiedad que usa el programador para que la GUI
tenga el comportamiento deseado. Si la tarea que se tiene que ejecutar al activar un
control es simple, lo normal es poner esta tarea en el campo Callback del Property
Inspector. Por ejemplo, Callback=grid on 0 Cal Iback=close.
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Pero cuando la tarea es compleja (realizar unos calculos y representarlos con cierta
apariencia, por ejemplo) es mejor usar el fichero *.m que se crea por defecto al salvar
el fichero *.fig o bien usar otro fichero *.m escrito por el usuario (esta segunda
opcion se verd a continuacion, en el apartado 7, para ver un ejemplo donde se edita el
fichero *.m que se crea por defecto, ver el apartado 8).

4. Crear los menus y submenus y asignarles las propiedades Label, Tag y Cal lback (Si
éste es simple).

5. Editar el fichero *.m que controla el comportamiento de la aplicacion. Se
recomienda ir verificando el comportamiento de cada control a medida que se edita
este fichero.

6. Verificar el comportamiento de la GUI en su totalidad.

7. Ejemplo (version 6.x)
7.1 Creacién de la ventana principal y de los controles

Guide: Para abrir la utilidad GUIDE teclear >>guide en la ventana de comandos o bien
clicar en el icono ﬂ de la barra de herramientas.

GUIDE Quick Start x|

Create New GUI | Open Exsting GUI I

GUIDE templates - Previe
< Blank GUI (Detaul)

<\ GUIwith Uicontrols
@\ GUlwith Axes and Menu
ﬂ Modal Guestion Dialog

BLANK

I Save on startup as; |CiArchivos de programaiMATLABIR 2 008 avworkiuntitl Erowse...

(o]} | Cancel | Help |
Fig. 12. GUIDE

Figura principal: Seleccionar la opcion Blank GUI (Default) a fin de crear una
figure nueva. En el menu de la figura, seleccionando “Tools 2GUI Options” se puede
cambiar la propiedad de redimensionado (el valor por defecto es Non-resizable pero se
puede ajustar a Proportional).

Creacion de los objetos: Insertar los objetos que se muestran en la Fig. 13 (dos axes
lﬁ" dos push buttons ., un edit text E‘ un static text :” .
y
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Propiedades de los objetos: Abrir el Property Inspector B de los siguientes
objetos y establecer las propiedades indicadas:

Objeto String Tag Cal Iback
Edit text frec frec temad(‘refresh’)
Static text Frecuencia (rad/s)
Push button 1 grid grid
Push button 2 SALIR SALIR tema4(‘salir’)

Verificar que en el Object Browser aparecen los Strings (entre comillas) y los Tags de la
tabla anterior. En cuanto a la propiedad Callback, esta propiedad permite que se ejecute
una funcién Matlab cuando se activa el objeto. En nuestro ejemplo, al clicar en el
pushbutton2, se ejecutara la subrutina “salir” de la funcion “tema4.m” (estd funcién
esta definida en el siguiente apartado).

w fig_temad.fig

Wiew Layvout Tools Help

EEH EHY >

Frecuencia (rad/s)

axes| I frec

. Object Browser

[ER | ciqure (fig temad)
grid | i{iaxes [axesl)
axes? AR [ff uicontrol (FREC "frec™)
T nicontrol (textl "Frecuencia (radi/s)™)
[#] uicontrol (pushbuttonl "grid™)

@] uicontrol (SALIR "SALIR™)
i{iaxes [axes2)

—

Fig. 13. Objetos en una GUI

Salvar la GUI con el nombre fig_tema4.fig.

7.2 Edicion de la funcién *.m de la aplicacién. Callbacks
Abrir el editor de ficheros M y editar la funcion siguiente (tema4.m)
function tema4(accion)
ifT nargin<l

accion="ini";
end
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global ctrl
if strcmp(accion, "ini")

f=openftig("fig_temad");
ctril=guihandles(f)

elseif strcmp(accion, “refresh®)
frec=str2double(get(ctrl.FREC, "string))
t=0:0.1:20;
y=t._.*sin(frec*t);
plot(t,y, "Parent”,ctrl_axesl)

elseif strcmp(accion, "salir™)

close
clear global ctrl

end
Notar la conversion str2double del valor frec y como se le ha indicado al objeto line
en cudl de los dos axes debe situarse.
7.3 Ejecucion de la aplicaciéon

Basta con teclear el nombre del fichero *.m en la ventana de comandos. El resultado se
muestra a continuacion:

) fig_temad Qlil@‘
>> temad
1
Ctr I = 08 Frecuencia (radis)
figurel: 168.0074 06 b
axes2: 14.0079
SALIR: 13.0079 e
pushbuttonl: 12.0079 02
textl: 11.0082 o ‘ , , ‘ ‘
FREC: 174_0072 u] 0.2 0.4 06 0.8 1
axesl: 169.0073 1
.
1]
0 045 1

Notar que la funcion guihandles devuelve una estructura con los handles de los
objetos de la GUI. Los campos de la estructura son los tags de los objetos.

En el cuadro Edit escribir diferentes valores de frecuencia y ver qué sucede al pulsar
Enter. Probar el funcionamiento de los botones “grid” y “SALIR”.
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J fig_temad EII@EI 2 fig_temad EHEWZ\
20 20
Frecuencia (radis) Frecuencia (rad/s)
10 4 10 4
a 4 1] H
-10 R -10
o0 . . \ 50 . \ \
0 5 10 15 20 0 5 10 15 20
— ([re—
- =
o] PO R )=y SR S

Fig. 14. Funcionamiento de la GUI

8. Ejemplo (version 7.x)
8.1 Creacién de la ventana principal y de los controles

Guide: Para abrir la utilidad GUIDE teclear >>guide en la ventana de comandos o bien
clicar en el icono ﬂ de la barra de herramientas.

_[lx|
Fe Edt View Lavout Took Hep

x De@ ien- aBB Au -

200 240 0 240 L) a0 180 -
Greate New OUL | Open Exsting 6UI |

GUIDE ternplates Previes

<) Blank GUI (Defaul)
<\ GUIwith Uicontrols
< GUIwith Axes and Menu

=1C]x]

oo v [ |

Command-lin accessibility: IL'nIIIJork (G becomes Current Figure within Callbacks)

ﬂ Modal Question Dialog

BLANK

 Generate FIG-file and b-ile

¥ Generate callback fnction profolypes

¥ GUI allows only n instance to nan (singleton)

¥ Use system color scheme for background {recommended)

B

I™ Save on startup as: [ClArchivies de programaWATLABR 200Gatworkiuntitl Browse.
€ Generate FIG-fle onty

OK I Cancel | Help | _.! Ok Cancel Halp

Fig. 15. GUIDE

Figura principal: Seleccionar la opcion Blank GUI (Default) a fin de crear una
figure nueva. En el menu de la figura, seleccionando “Tools 2GUI Options” se puede
cambiar la propiedad de redimensionado (el valor por defecto es Non-resizable pero se
puede ajustar a Proportional).

Creacion de los objetos: Insertar diversos controles (por ejemplo, un par de axes lﬁ"

un pop-up mena #, un panel =, dos pushbuttons ). Poner los pushbuttons
dentro del panel y observar como a partir de ahora se convierten en un grupo que se
puede desplazar y redimensionar a la vez. En el caso de arrastrar y clicar en un control
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Activex X aparecera una ventana listando todos los controles Actiivex disponibles en
el ordenador.

& untitled2.fig i ] 3
Fle Edit Wew Layout Took Help
DEE|i2ae - 2EBHB 6% »
D e S e =1olx]
= >
®| &%
ol | o aues’ 0.8
—| - Pop-up Me... =
=] | = 06 [Fopup voma o]
fed 04
] i | e S 03
|
. I q
ST 0 05 1
rPanel 1
@ Panel
A axes3 Fush Button — 08
Push Button
b 06
] ush Button
04 Push Button
] 02
O Y —
0 05 1
4

Fig. 16. Controles

Clicar en y para acceder a las herramientas de alineacion, distribucion y
ordenamiento de objetos.

Propiedades de los objetos: Abrir el Property Inspector B de los siguientes
objetos y establecer las propiedades indicadas:

Objeto String Title Tag Cal Iback
Push button 1 grid bot grid
Push button 2 salir bot salir | close
Uipanel 1 botones
Pop up menu 1 | iniciolbolas|sombrero

Por ejemplo, el Property Inspector del segundo pushbutton quedar asi:

& Property Inspector ;lglil
Licontrol (bot_salir "salir)

EH-BackgroundCalar @ — [
----- BeingDeleted off

----- BusyAction guele -

----- ButtonDownFon &

----- CData ﬂ [0x0 double array]

----- Callback close &

Fig. 17. Edicion de las propiedades de los controles con el Property Inspector

Para cambiar el String del popupmenu clicar en el icono £ dentro de su Property
Inspector y poner la lista de etiquetas en una columna.
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Activacion de la ventana y creacion del fichero m: Clicar en ™ o seleccionar
“Tools>Run”. Indicar cual sera el nombre de la ventana, por ejemplo, “demo_gui”.
Por defecto se crean dos ficheros: demo_gui.fig Yy demo_gui.m. El fichero *.m

asociado a la GUI puede abrirse desde el GUIDE, basta con clicar en 0 hacer
View>M-file Editor.

El contenido del fichero *.m se estructura en diversas funciones. Para verlas clicar en el
icono ¥ disponible en el editor de ficheros M.

El fichero *.m creado por defecto para nuestro ejemplo es el siguiente (version 7.2):

function varargout = demo_gui(varargin)
% DEMO_GUI M-file for demo_gui.fig
% Comentarios de ayuda

% Begin initialization code - DO NOT EDIT

gui_Singleton = 1;

gui_State = struct("gui_Name”®, mFilename, -
“gui_Singleton®, gui_Singleton,
“gui_OpeningFcn®, @demo_gui_OpeningFcn,
“gui_OutputFcn®, @demo_gui_OutputFcn,
"gui_LayoutFcn®, [1 ., -
“gui_Callback®, [D:;

if nargin && ischar(varargin{l})

gui_State._gui_Callback = str2func(varargin{l});

end
if nargout
[varargout{l:nargout}] = gui_mainfcn(gui_State, varargin{:});
else
gui_mainfcn(gui_State, varargin{:});
end

% End initialization code - DO NOT EDIT

% --- Executes just before demo_gui is made visible.

function demo_gui_OpeningFcn(hObject, eventdata, handles, varargin)
% This function has no output args, see OutputFcn.

% hObject handle to figure

% eventdata reserved - to be defined in a future version of MATLAB
% handles structure with handles and user data (see GUIDATA)

% varargin command line arguments to demo_gui (see VARARGIN)

% Choose default command line output for demo_gui
handles.output = hObject;

% Update handles structure
guidata(hObject, handles);

% UIWAIT makes demo_gui wait for user response (see UIRESUME)
% uiwait(handles.figurel);

% --- Outputs from this function are returned to the command line.
function varargout = demo_gui_OutputFcn(hObject, eventdata, handles)
% varargout cell array for returning output args (see VARARGOUT);

% hObject handle to figure

% eventdata reserved - to be defined in a future version of MATLAB
% handles structure with handles and user data (see GUIDATA)

% Get default command line output from handles structure
varargout{l} = handles.output;

% --- Executes on button press in pushbuttonl.
function pushbuttonl_Callback(hObject, eventdata, handles)
% hObject handle to pushbuttonl (see GCBO)
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% eventdata reserved - to be defined in a future version of MATLAB
% handles structure with handles and user data (see GUIDATA)

% --- Executes on button press in pushbutton2.

function pushbutton2_Callback(hObject, eventdata, handles)

% hObject handle to pushbutton2 (see GCBO)

% eventdata reserved - to be defined in a future version of MATLAB
% handles structure with handles and user data (see GUIDATA)

% --- Executes on selection change in popupmenul.

function popupmenul_Callback(hObject, eventdata, handles)

% hObject handle to popupmenul (see GCBO)

% eventdata reserved - to be defined in a future version of MATLAB
% handles structure with handles and user data (see GUIDATA)

% Hints: contents = get(hObject, "String") returns popupmenul contents as
cell array

% contents{get(hObject, "Value®)} returns selected item from
popupmenul
% --- Executes during object creation, after setting all properties.

function popupmenul_CreateFcn(hObject, eventdata, handles)

% hObject handle to popupmenul (see GCBO)

% eventdata reserved - to be defined in a future version of MATLAB

% handles empty - handles not created until after all CreateFcns called

% Hint: popupmenu controls usually have a white background on Windows.
% See ISPC and COMPUTER.
if ispc && isequal(get(hObject, "BackgroundColor®),
get(0, "defaultUicontrolBackgroundColor*))
set(hObject, "BackgroundColor”®, "white");
end

Notar que hay una funcién de inicializacion, una de finalizacion (funciones
demo_gui_OpeningFcn Yy demo_gui_OutputFcn) Yy, a continuacion, varias otras
funciones, cada una correspondiente a un Cal Iback de un objeto concreto.

Nota: Hay diferentes tipos de Callbacks, los Callbacks propiamente dichos y otros que
se generan dependiendo del tipo de objeto (como, por ejemplo, CreateFcn, DeleteFcn,
ButtonDownFcn, etc...). Para ver la lista entera de Callbacks se puede ir al guide y
seleccionar la opcion de menu View->View Callbacks. No es necesario rellenar todos
los Callbacks de un objeto (a veces ya vienen rellenos por defecto con instrucciones de
inicializacion). Lo habitual es trabajar solo con las propiedades Callback propiamente
dichas.

En una aplicacion tipica, el usuario puede crear sus propias funciones auxiliares y poner
las a continuacion de las generadas automaticamente. También es posible llamar a la
funcién demo_gui con argumentos de entrada (notar el uso de varargin).

Argumentos de entrada hObject, evendata y handles: Sirven para que todas las
funciones internas se pasan informacion entre ellas. En concreto, handles es una
estructura cuyos campos son los tags de los objetos graficos y el valor de dichos campos
es el nimero de handle asociado, por ejemplo,

handles =
figurel: 173.0063
popupmenul: 187.0063
uipanell: 184.0063
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axes2: 179.0063
axesl: 174.0063
bot salir: 186.0063
bot _grid: 185.0063

La variable hObject contiene el nimero de handle de cada objeto. El usuario puede
afladir mas campos a la variable handle conteniendo, por ejemplo, datos de la
aplicacion. O también puede crear otra variable de tipo estructura independiente para
contener los datos de la aplicacién y dejar la variable handles s6lo para los
identificadores de los objetos.

8.2 Edicion de la funcién *.m de la aplicacién

Cabecera: La cabecera de la funcion de aplicacion contiene unos comentarios de ayuda
y unos comandos de inicializacién que no es necesario editar:

function varargout = demo_gui(varargin)
% DEMO_GUI M-file for demo_gui.fig

%

%bla,bla,bla

%

% Begin initialization code - DO NOT EDIT

gui_Singleton = 1;

gui_State = struct("gui_Name®, mFilename, ...
"gui_Singleton®, gui_Singleton, ...
"gui_OpeningFcn®, @demo_gui_OpeningFcn, ...
"gui_OutputFcn®, @demo_gui_OutputFcn, ...
"gui_LayoutFcn®, [1 , ---
"gui_Callback", D

if nargin && ischar(varargin{l})

gui_State.gui_Callback = str2func(varargin{l});
end

if nargout
[varargout{l:nargout}] = gui_mainfcn(gui_State, varargin{:});
else
gui_mainfcn(gui_State, varargin{:});
end
% End initialization code - DO NOT EDIT

A continuacion de la cabecera aparecen una serie de funciones:
Funcion OpeningFcn: Es la funcion que se ejecuta cuando se inicia la GUI. Notar que
acepta parametros de entrada adicionales por medio del argumento varargin.

En esta funcidon se pueden generar y/o cargar los datos iniciales. También se puede
Ilevar a cabo una primera representacion grafica.

En este primera function hay dos instrucciones que aparecen por defecto

handles.output = hObject;
guidata(hObject, handles);
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La primera instruccién, handles.output = hObject;, afiade el campo “output” a la
variable handles y le asigna el handle correspondiente a la figure, hObject. La variable
handles queda pues, asi:

handles =

figurel: 173.0013

axes3: 6.0020
popupmenul: 182.0013
uipanell: 179.0013
axesl: 174.0013
bot salir: 181.0013
bot _grid: 180.0013
output: 173.0013

Notar que handles.output (es decir, la ventana principal de la aplicacion) sera la salida
minima (por defecto) del fichero m (ver funcion OutputFcn mas adelante).

La segunda instruccion, guidata(hObject, handles);, sirve para actualizar la
estructura de handles si se han hecho cambios (por ejemplo, si hemos generado nuevos
datos y los hemos guardado en nuevos campos de handles).

En nuestro ejemplo, usaremos la funcién OpeningFcn para generar un grafico de inicio
y representarlo. La funcion OpeningFcn quedaréa asi

function demo_gui_OpeningFcn(hObject, eventdata, handles, varargin)
inicio(handles);

handles.output = hObject;

guidata(hObject, handles);

La subrutina inicio la definiremos al final del fichero m asi:

function inicio(handles)

newplot;

x=linspace(0,2*pi);y=exp(J*x);
Ffill(real(y),imag(y),"y", "Parent” ,handles.axesl);
hold(handles.axesl, "on")
01=y*0.1-0.4+j*0.2;02=y*0.1+0.4+j*0.2;

patch(real (ol),imag(ol), k", "Parent” ,handles.axesl);
patch(real (02),imag(o2), k", "Parent” ,handles.axesl);
x=linspace(-pi,0);y=exp(J*x)*0.5-0.2*};
plot(real(y),imag(y), "k", "Parent” ,handles.axesl)
axis(handles.axesl, "off"),axis(handles.axes2, "off"),
hold(handles.axesl, "off")

Notar que hemos usado la propiedad ‘Parent’ para indicar en cuales de los dos axes hay
que realizar la representacion. Notar también que hemos usado la funcion hold y la
funcion axis indicando en cada caso a qué axes queriamos aplicar los cambios.

La instruccién newplot se ha afiadido por precaucion, para limpiar la figure, y evitar
posibles superposiciones de graficos.

Con este codigo, la ejecucion inicial de la GUI da lugar a la siguiente pantalla:
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inicio =
hotanes
grid
salir

Funcion OutputFcn: Es la funcion que se ejecuta como salida de la GUI. Notar que es
posible que la GUI genere variables de salida adicionales (ademas del handle de la
figure principal) adicionales por medio del argumento varargout. Esta funcion no la
tocaremos en nuestro ejemplo.

function varargout = demo_gui_OutputFcn(hObject, eventdata, handles)
varargout{l} = handles.output;

Funciones de Callback de los controles:

Funcion asociada al boton bot _grid: En esta funcion ponemos los comandos que
queremos que se ejecuten al clicar sobre el botdn bot_grid (también podriamos haberlas
escrito en el Property Inspector). Puesto que el callback es el comando grid a secas ello
indica que cuando cliquemos en bot_grid, se pondra y quitara la rejilla de manera
alternativa.

function bot_grid_Callback(hObject, eventdata, handles)
grid(handles.axesl)
grid(handles.axes?2)

Funcion asociada al boton bot_salir: En esta funcién podemos poner los comandos
que queremos que se ejecuten al clicar sobre el botdn bot_salir. En este ejemplo no
pondremos nada puesto que ya hemos rellenado el campo Callback del property
inspector de bot_salir con el comando “close”.

function bot_salir_Callback(hObject, eventdata, handles)

Funciones asociadas al pop up menu: Al crear el objeto pop up menu nos han
aparecido dos funciones de callbacks: callback y createFcn. Sélo editaremos la
primera. En ella, en funcion de la seleccion del pop up menu ejecutaremos una
representacion grafica u otra, por ejemplo,

function popupmenul_Callback(hObject, eventdata, handles)
val=get(hObject, "Value™);

ETSETB. MATLAB. Fundamentos y/o Aplicaciones. Curso 11/12b 22



Tema 4. Interficie grafica con el usuario

str=get(hObject, "String”);
switch str{val}
case "bolas”
[B1,B2]=bolas;
rep_bolas(B1,B2,handles);
case "sombrero”
S=sombrero;
rep_sombrero(S,handles);
case "inicio”
inicio(handles);
end

function popupmenul CreateFcn(hObject, eventdata, handles)
if ispc && isequal(get(hObject, "BackgroundColor®),
get(0, "defaultUicontrolBackgroundColor®))
set(hObject, "BackgroundColor*,"white");
end

Al final del fichero hemos afiadido las subrutinas que generar y representan las bolas y
el sombrero. Estas son:

function [B1l,B2]=bolas
[x,y,z]=sphere(25);
Xx1=x-2;yl=y-3;z1=z7;
X2=X*2;y2=y*2;22=7*2;
B1={x1,y1,z1};B2={x2,y2,z2};

function S=sombrero

warning("off", "MATLAB:divideByZero");
[x,y]=meshgrid(-10:0.5:10,-10:0.5:10);
z=sin(sgrt(xX."2+y."2)) ./sqrt(x.-"2+y."2);
S={x,y,z};

function rep_bolas(B1,B2,handles)
mesh(B1{1},B1{2},B1{3}, "Parent”,handles.axesl),
hold(handles.axesl, "on")
mesh(B2{1},B2{2},B2{3}, "Parent” ,handles.axesl),
set(handles.axesl, "XLim",[-3 3], YLim",[-3 3], ZLim",[-3 3]D);
hold(handles.axesl, "off");

%

contour(B1{1},B1{2},B1{3}, "Parent” ,handles.axes?2),
hold(handles.axes2,"on")
contour(B2{1},B2{2},B2{3}, "Parent” ,handles.axes?2),
set(handles.axes2, "XLim",[-3 3], "YLIim",[-3 3]);
hold(handles.axes2, "off");

%

grid(handles.axesl, "off");grid(handles.axes2, "off");

function rep_sombrero(S,handles)
mesh(S{1},S{2},S{3}, "Parent” ,handles.axesl);

contour (S{1},S{2},S{3}, "Parent” ,handles.axes?2),
grid(handles.axesl, "off");grid(handles.axes2, "off");
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8.3 Ejecucion de la aplicacion

Para ejecutar la GUI basta con teclear

>> demo_gui

El resultado se muestra a continuacion. Al seleccionar la opcién “bolas” y clicar en el
botdn bot_grid el resultado es el siguiente:

_lofx| =lo| x|

Ibolas =

g hotones
2
1 Q arid
0
-1 salir |
-2
-3
2 0 2

Y al seleccionar la opcién “sombrero™:

) demo_gui _|d il _ |:| El

sombrera sombrero M

hotones hotones

yric
salir salir |

Y al clicar en el bot_salir se cierra la GUI.
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